All pages in tagged with #Conflicts


NodeJS Package Conflicts on Ubuntu 14.04

Fixing issues with installing Cordova command-line tools on Ubuntu

Wednesday Jul 16, 2014 — 1 minute read — 157 words

If you’re developing with Cordova/PhoneGap/Ionic apps on the Ubuntu platform, chances are you’re using the cordova-cli package. For a while now, the nodejs and nodejs-legacy packages have collided around a singe man file. Unfortunately, the simple file collision can break the entire package manager and make it difficult to update anything. Add dkpg --force-overwrite Flag The solution is very simple. Just add the dkpg --force-overwrite flag to your apt-get commands. So this: sudo apt-get install cordova-cli becomes: sudo apt-get -o Dpkg::Options::="--force-overwrite" install cordova-cli Of course, you probably don’t want to type that all the time.

Read More